Documentation

Documentation sections

Importing source files

To import a model, use File > Import Model, press Ctrl + J, or click the import model button in the toolbar.

AutoVAT import model button highlighted in the toolbar

Make the required transform adjustments. The asset will appear in the target engine as it appears in the preview.

Imported model shown in the AutoVAT preview workspace
Tip What you see in the AutoVAT preview is how it will appear in the editor. The transform gizmo matches the engine for the selected target platform.

Material Settings

Use the Materials area on the right to review the material slots from the imported model and assign graphs to them. Use the tabs at the top to view or add material graphs..

AutoVAT Materials area and Graph tab highlighted

Each imported material slot can use a material graph assignment. Use the drop-down menu to select a graph for the slot. Use Unset to remove the current assignment.

AutoVAT default material graph preview

Material0 is the default material graph for the main mesh. You must always have at least one material graph, so you cannot close Material0. Use the Name field to rename the material. Add or connect nodes in the graph to change the material. Material0 contains a Texture Sample node by default.

AutoVAT material graph preview

Use the Settings panel on the left to change the material name, sidedness, and VAT processing. You can also enable grid snapping and set the grid snap size in this panel.

AutoVAT material graph preview

Here I set this materials base color to a fixed color using a vector3 constant. I did this for my other needed materials for my tree. Then I set the slots to each graph using the side bar.

Showcasing a tree with amterials applied to it
Tip To change the editor background color, select View > Background Color.

To play an animation, select it from the Animation menu, and then select Play.

Playing an animation on a mesh